Häufigkeitsverteilungen mit Excel

Um aus einer großen Menge von Daten Häufigkeitsverteilungen mit Excel zu erstellen gibt es verschiedene Wege. Zum Beispiel mit Pivottabellen oder unter Verwendung der Funktion Summewenn. Ich möchte an diesem Beispiel zeigen wie einfach und schnell man dieses Problem mittels Array-Formeln lösen kann.

Im Bereich $A$2:$A$22 stehen die Daten. In den Spalten C und D die Grenzen für die Häufigkeitsverteilung. Die Funktion Summe enthält das Produkt aus zwei Wahrheitswerten. Zunächst wird geprüft, ob der Wert größer als die untere Grenze ist: ($A$2:$A$22>C2). Anschließend wird geprüft, ob der Wert kleiner oder gleich der oberen Grenze ist: ($A$2:$A$22<=D2). Das Produkt beider Wahrheitswerte (WAHR=1, FALSCH=0) ist nur dann wahr wenn beide Wahrheitswerte wahr sind, entspricht also einer UND-Verknüpfung. Die Summe über allen WAHR-Werte ist die Anzahl der Daten die innerhalb dieser Grenzen liegen.

{=SUMME(($A$2:$A$22>C2)*($A$2:$A$22<=D2))}

Nicht vergessen! Da es sich um eine Array-Formel handelt, muss die Formel mit Strg+Shift+Enter abgeschlossen werden.

Häufigkeitsverteilungen mit Excel

  A B C D E
1 Werte von bis Häufigkeit
2 1   0 2 3
3 2   2 4 6
4 3   4 6 6
5 4   6 8 4
6 5   8 10 2
7 6        
8 7        
9 8        
10 9        
11 10        
12 2        
13 3        
14 4        
15 5        
16 6        
17 7        
18 8        
19 4        
20 5        
21 6        
22 4        

Formeln der Tabelle
Zelle Formel
E2 {=SUMME(($A$2:$A$22>C2)*($A$2:$A$22<=D2))}
E3 {=SUMME(($A$2:$A$22>C3)*($A$2:$A$22<=D3))}
E4 {=SUMME(($A$2:$A$22>C4)*($A$2:$A$22<=D4))}
E5 {=SUMME(($A$2:$A$22>C5)*($A$2:$A$22<=D5))}
E6 {=SUMME(($A$2:$A$22>C6)*($A$2:$A$22<=D6))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Your rating: Keine Average: 4.8 (5 votes)